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Purpose of this guide

This QuickStart Guide for M-Business Anywhere, Version 5.7 is provided to help a 
developer who is new to the M-Business Anywhere environment achieve the 
following objectives within 30-60 minutes:

■ Install M-Business Anywhere server

■ Install M-Business Anywhere client on a mobile device

■ Set up a test user on M-Business Anywhere server

■ Set up a test channel on M-Business Anywhere server that will deliver web 
content to the mobile device

■ Sync the the mobile device with the M-Business Anywhere server to download 
and view the test channel content

When you are finished with this guide, you will be ready to concentrate on the 
design issues involved in getting your target web content to work the way you want 
it to on the mobile devices that you must support. 

Location of other M-Business Anywhere documentation
In order for the cross references to other M-Business Anywhere documents to work 
properly as clickable links, all of the M-Business Anywhere documentation PDF files 
must be located in the same directory. 

1. You may download the complete set of M-Business Anywhere documentation 
from:

http://www.ianywhere.com/developer/product_manuals/
mbusiness_anywhere/ 

2. Under “Current Version,” click the Complete doc set link, then unzip the files 
into one directory.

http://www.ianywhere.com/developer/product_manuals/mbusiness_anywhere/index.html
http://www.ianywhere.com/developer/product_manuals/mbusiness_anywhere/index.html
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What you need to continue 

1. Make sure you have a workstation set up to use for testing.

This workstation may be the same host machine on which M-Business 
Anywhere server will be installed, or any other worstation that can connect to 
the host over a network.

Operating system - The workstation must have one of the following versions of 
Microsoft Windows:

■ 98 SE

■ NT 4.0 Workstation with Service Pack 6

■ 2000 Professional with Service Pack 2

■ XP Professional

■ XP Home

Browser - The workstation must have one of the following supported browsers:

■ Internet Explorer 5.5

■ Internet Explorer 6.0

■ Netscape Communicator 4.75

■ Netscape Navigator 6.1

Note You will need to log in as an administrator on the workstation in order to install 
the M-Business Anywhere client software.

2. Make sure you have a mobile device set up to use for testing.

You need to have a mobile device with a cradle attached to the workstation 
from which you will access the M-Business Anywhere server Administrator 
Console and sync the device. If you are using a Windows XP workstation, the 
workstation itself can serve as the test device.

Palm requirements - Palm OS devices running version 4.x or 5.x of the Palm OS 
1.5MB free memory.

Pocket PC requirements - Pocket PC OS devices, including Pocket PC and 
Handheld PC devices, running version 3.0 and using ARM processors with 
1.8MB free memory.

Windows XP requirements - Windows XP Tablet Edition, 2002 version, with 
service pack 1.

Note Before proceeding, the device should already be set up to sync at your desktop 
workstation. Palm devices sync via HotSync, Pocket PC devices sync via 
ActiveSync, and Windows XP devices sync directly via a network connection. If 
you have just received a new device, refer to the documentation that came with 
it to set it up correctly. 
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3. Make sure the Windows server on which you plan to install M-Business Any-
where server meets the following hardware and software requirements:

■ 256MB RAM 

■ Pentium II 233 MHz or better CPU 

■ One of the following operating systems: 
- Windows NT Server 4 with Service Pack 6a 
- Windows 2000 Server with Service Pack 4 
- Windows 2003 Server 

4. Make sure you have the admin user login info for the target server. 
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Installing the M-Business Anywhere server on Windows

Note If you are upgrading an existing M-Business Anywhere installation, or installing on 
a Unix platform, this guide does not cover those situations. See the Administrator 
Guide for M-Business Anywhere Server, Version 5.7 for instructions.

Follow the instructions below to perform a new installation of M-Business 
Anywhere server on a Windows machine. If you need more details on any of the 
steps, refer to the Administrator Guide for M-Business Server, “Installing M-Business 
Anywhere server on Windows” (page 46). 

1. On the target server, log in to Windows as an administrator.

2. Determine the port numbers that are already in use on the machine.

Note The M-Business Anywhere server installer will use port number 80 by default. If 
port 80 is already in use, you will need to specify another port number which is 
not in use.

■ Open a browser window on the server and enter this URL:
http://localhost:80 

■ If a non-error page is displayed, it means that a web server on that machine is 
already using port 80 — try the URL above with different port numbers until 
you find one that is not in use, then make a note of that port number for 
later reference. Do not use port numbers 8091 or 8099 — these will 
automatically be used by the M-Business Anywhere server.

3. Download the M-Business Anywhere server installer.

■ Open a browser and navigate to 
http://www.ianywhere.com/downloads/ 

■ Click the M-Business Anywhere Developer Edition link.

■ Fill in the form for the evaluation download and read the license agreement. 

■ Click the Agree and Submit button.

■ On the Download and Installation page, click the click here link in “To begin 
download process now, please click here” in the middle of the page.

■ On the M-Business Anywhere 5.5 for Windows Download page, click the 
Download button to the left of “M-Business Anywhere for Windows.”

■ Save the installer file, MBAnywhereW.exe, to a temporary location.

Note Your license number will be sent to you at the email address you supply in this 
step. You can start the installer immediately, but you will not be able to 
complete the installation until you have received your license number.

4. Run the M-Business Anywhere server installer.

■ Open the folder where you just saved the installer and double-click the 
MBAnywhereW.exe file to start the InstallShield Wizard.

■ After the Extracting Files panel completes, enter your server license number 
in the M-Business Anywhere Setup window that appears.

Get this from the email sent to the email address you gave in step 3 above.

http://www.ianywhere.com/downloads/index.html
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■ Accept the defaults on the rest of the panels until you reach the Sync Port 
panel. Here is the sequence you will see: 
- Server Functionality 
- Welcome 
- License Agreement 
- Choose Destination Location 
- Wireless Access SRP Key 
- User Friendly Server Name 
- Host Name 

The Sync Port panel is now displayed:

Figure 2-1                                           
Sync Port panel

Caution If port 80 is already in use on the target machine, enter another port number 
which is not in use on the Sync Port panel.

■ Clicke Next on the Sync Port panel to start the M-Business Anywhere setup 
process.

Note On the InstallShield Wizard Complete panel, you you can choose to restart 
your computer later, but you will not be able to continue with the steps that 
follow until you restart.

5. Verify that the installation was successful.

■ Restart the machine.

■ In a browser, navigate to http://localhost:8091.

If the M-Business Anywhere login page appears, the install was successful — 
continue. 
If the login page does not appear, start over with step 1 above.

After you have verified that the install was successful, go on with the next section, 
“Setting up a mobile device, test user, and test channel” (page 7).
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Setting up a mobile device, test user, and test channel

1. If the test device is an XP Tablet, proceed to step 3.

2. If the test device is Palm or Pocket PC, verify that the device is able to synchro-
nize with your desktop workstation. 

Palm devices sync via HotSync and Pocket PC devices sync via ActiveSync. Refer 
to the documentation that came with the device for detailed instructions. 

Once you have verified that the test device is able to synchronize, leave the 
device in its cradle.

Caution Do not proceed until you are able to synchronize your device.

3. Open the M-Business Anywhere server Administrator Console.

Navigate in your web browser to http://localhost:8091. 

Figure 2-2                                           
Download Client 
Software Only link 
on login screen

4. Click the New Account Registration link, near the center.

Specify necessary information when prompted.

5. Language: Select a language for the instructions, then click Next.

6. Platform: Select the platform for your test device, then click Next.

7. Download: Click the M-Business Client Software link.
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Caution Leave this page displayed and do not click the Next button until you have 
completed the M-Business Anywhere client installation. 

■ Save the installer to a temporary location.

■ Open the folder to which you just saved the installer.

■ Follow the directions on the Download page and in the InstallShield panels 
to complete the installation.

■ When the M-Business Client Installation Completed panel is displayed, click 
Finish to close the InstallShield panel and window.

■ Return to the Download window and click the Next button to display the 
Register page.

8. Register: Fill in the test user account information.

■ User Name, Password, and Confirm Password fields are required; the other 
fields are optional. 

■ For purposes of this QuickStart, you can use a one-character password, like 
“a” — this is easy to change later.

■ Click the Register button to display the Configure page.

9. Configure: Click the Configure Connection button to display the first Add 
M-Business Server panel.

■ Click Next to display the next Add M-Business Server panel.

■ Click Next to display the network test panel.

■ Click Next to test your network connection.

■ Wait for the Autodetect Network Connection message box to indicate 
“autodetection was successful.” If your network connection is not successfully 
detected, troubleshoot the problem and then click Detect Again.

■ After your network connection is successfully detected, click Done to close 
the Autodetect Network Connection message box and return to the main 
Add M-Business Server panel.

■ Click Finish to close the Add M-Business Server panel and return to the 
Configure page.

■ Click Finish to display the Conduits page for the user you just created.

10. On the Conduits page, click the Create Personal Channel button (scroll down).

The Create New Personal Channel page is displayed — shown below as it will 
appear after you fill in two key fields.
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Figure 2-3                                           
Create New Personal 
Channel form

11. On the Create New Personal Channel form, fill in these fields as follows:

■ for Title, enter Google Test 

■ for Location, enter http://www.google.com 

12. Click the View button to be sure the URL works.

13. Close the browser window opened by the View button.

14. If Google did not display, fix the URL and click the View button again.

15. Click the Create button at the bottom of the form to create the channel.

You are returned to the Conduits page for your test user.
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Testing your device/user/channel setup

1. Sync your test device.

See the documentation that came with your device for instructions.

2. If your test device is not a Windows XP device, sync again.

On all platforms except Windows XP, the first sync simply installs the M-Business 
Anywhere client on the device. The second sync downloads the test channel 
content — the Google home page.

3. Start up the M-Business Anywhere client on the device.

Palm OS:
- tap the Applications silk-screen icon 

- tap the M-Business Client icon

Pocket PC OS:
- tap Start|Programs 
- tap the M-Business Client icon

Windows XP:
- tap or click Start|Programs 
- tap or click he M-Business Client icon

4. Make sure the device is offline.

Depending on your device and connection type, your device may be online 
after syncing. In order to see how the M-Business Anywhere client handles 
offline form submissions in the steps below, your test device must be offline:

Palm OS:
- tap the iAnywhere page title to open the menus
- on the Channels menu, tap Work Offline 

Pocket PC OS:
- tap the Tools menu, then tap Work Offline (if greyed out, device is already 
offline)

Windows XP:
- tap or click the File menu, then tap or click Work Offline 
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5. Under Personal Channels, tap the Google Test link to display your channel.

Figure 2-4                                           
Google Test link on 
device

6. Look in the Forms Manager.

Now that the test channel is properly synchronized to your device, we'll 
demonstrate a simple offline form submission. We’ll use the Forms Manager on 
the device to view an empty forms queue, a forms queue with pending forms, 
and finally the successful results of our form submission. First view the empty 
forms queue:

■ Palm OS - Tap the Google Search page title to open the menus, then on the 
Channels menu, tap Forms Manager.

■ Pocket PC OS - Tap the View menu at the lower left, then tap 
Forms Manager.

■ Windows XP - Tap the View menu at the top, then tap Forms Manager.

The Forms Manager opens, displaying a message beginning, “You have no 
pending form submissions...”

7. Perform a search.

■ Tap the Back button to return to the Google Search page.

■ Tap in the text field immediately above the Google Search button.

■ Type w3c as the search term.

■ Tap the Google Search button.

A message is displayed indicating that “your submission... will be sent during 
the next Synchronization.”

■ Tap OK to acknowledge the message and return to the Google Search page.

8. Perform another search.

■ Tap in the text field immediately above the Google Search button.

■ Type ieee as the search term.

■ Tap the Google Search button.

■ Tap OK to acknowledge the message.



QuickStart Guide for M-Business Anywhere, Version 5.7

iAnywhere, Inc. Page 12 of 13

9. Look in the Forms Manager again.

■ Palm OS - Tap the Google Search page title to open the menus, then on the 
Channels menu, tap Forms Manager.

■ Pocket PC OS - Tap the View menu at the lower left, then tap 
Forms Manager.

■ Windows XP - Tap or click the View menu at the top, then tap 
Forms Manager.

The Forms Manager opens, this time displaying one entry for each search form 
you just submitted. The “pending” status indicates that these forms have been 
submitted offline on the device, but have not yet been submitted to the server 
in a sync.

10. Sync your test device.

There are several different ways to sync your device. In order to ensure that 
your device remains in offline mode, use the method listed below for your 
platform:

■ Palm OS - Sync the device through HotSync; see the documentation that 
came with the device for instructions.

■ Pocket PC OS - Sync the device through ActiveSync. Typically you just place 
the device in the cradle; see the documentation that came with the device 
for instructions.

■ Windows XP - In the M-Business Anywhere client on the device, tap or click 
the File menu at the top, then tap Sync.

When the sync is complete, the M-Business Anywhere client on the device 
automatically returns to its home page.

11. Look in the Forms Manager again.

■ Palm OS - Tap the Google Search page title to open the menus, then on the 
Channels menu, tap Forms Manager.

■ Pocket PC OS - Tap the View menu at the lower left, then tap 
Forms Manager.

■ Windows XP - Tap or click the View menu at the top, then tap 
Forms Manager.

The Forms Manager opens, still displaying one entry for each search form you 
submitted, but this time the “success” status indicates that these are the 
response forms returned by the server.

12. View your search results pages.

■ Tap the success link to display the search results for that form.

■ Tap the Back button to return to the Forms Manager to view the other 
search results page.

Note Tapping any link on one of your search results pages will get a “Page not 
available” message. If you get this message now, tap the Back button to return 
to the Forms Manager.
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Next steps

After the test/demo channel sync is successful, to create an application or mobilize 
an existing desktop web application, continue with the Introduction to M-Business 
Anywhere, CHAPTER 3., “Mobile application design guidelines”.


	Purpose of this guide
	Location of other M�Business Anywhere documentation

	What you need to continue
	Installing the M-Business Anywhere server on Windows
	Setting up a mobile device, test user, and test channel
	Testing your device/user/channel setup
	Next steps

