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Purpose of this guide

This Administrator Guide for M-Business Anywhere Server, Version 6.0 is provided to help 
a developer who is new to the M-Business Anywhere environment achieve the 
following objectives within 30-60 minutes:

■ Install M-Business Server

■ Install M-Business Client on a mobile device

■ Set up a test user on M-Business Server

■ Set up a test channel on M-Business Server that will deliver web content to the 
mobile device

■ Sync the the mobile device with the M-Business Server to download and view 
the test channel content

When you are finished with this guide, you will be ready to concentrate on the 
design issues involved in getting your target web content to work the way you want 
it to on the mobile devices that you must support. 

Location of other M-Business Anywhere documentation
In order for the cross references to other M-Business Anywhere documents to work 
properly as clickable links, all of the M-Business Anywhere documentation PDF files 
must be located in the same directory. 

1. You may download the complete set of M-Business Anywhere documentation 
from:

http://www.ianywhere.com/developer/product_manuals/
mbusiness_anywhere/ 

2. Under “Current Version,” click the Complete doc set link, then unzip the files 
into one directory.

http://www.ianywhere.com/developer/product_manuals/mbusiness_anywhere/index.html
http://www.ianywhere.com/developer/product_manuals/mbusiness_anywhere/index.html
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What you need to continue 

1. Make sure you have a workstation set up to use for testing.

This workstation may be the same host machine on which M-Business Server 
will be installed, or any other worstation that can connect to the host over a 
network.

Operating system - The workstation must have one of the following versions of 
Microsoft Windows:

■ 98 SE

■ 2000 Professional with Service Pack 4

■ XP Professional

■ XP Home

Browser - The workstation must have one of the following supported browsers:

■ Internet Explorer 5.5

■ Internet Explorer 6.0

■ Firefox 1.0

Note You will need to log in as an administrator on the workstation in order to install 
the M-Business Client software.

2. Make sure you have a mobile device set up to use for testing.

You need to have a mobile device with a cradle attached to the workstation 
from which you will access the M-Business Server Administrator Console and 
sync the device. If you are using a Windows XP workstation, the workstation 
itself can serve as the test device.

Palm requirements - Palm OS devices running version 4.x or 5.x of the Palm OS 
2 MB free memory.

Pocket PC requirements - Pocket PC OS devices, including Pocket PC and 
Handheld PC devices, running version 3.0 and using ARM processors with 
2 MB free memory.

Windows XP requirements - Windows XP Tablet Edition, or Windows XP 
Professional

Note Before proceeding, the device should already be set up to sync at your desktop 
workstation. Palm devices sync via HotSync, Pocket PC devices sync via 
ActiveSync, and Windows XP devices sync directly via a network connection. If 
you have just received a new device, refer to the documentation that came with 
it to set it up correctly. 

3. Make sure the Windows server on which you plan to install M-Business Server 
meets the following hardware and software requirements:

■ 2 GB RAM 

■ Pentium 4 2.5 GHz or better CPU 
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■ One of the following operating systems: 
- Windows 2000 Server with Service Pack 4 
- Windows 2003 Server with Service Pack 1

4. Make sure you have the admin user login info for the target server. 
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Installing the M-Business Anywhere server on Windows

Note If you are upgrading an existing M-Business Anywhere installation, or installing on 
a Unix platform, this guide does not cover those situations. See the Administrator 
Guide for M-Business Anywhere Server for instructions.

Follow the instructions below to perform a new installation of M-Business Server on 
a Windows machine. If you need more details on any of the steps, see the 
Administrator Guide for M-Business Server, “Installing M-Business Anywhere server on 
Windows” topic. 

1. On the target server, log in to Windows as an administrator.

2. Determine the port numbers that are already in use on the machine.

Note The M-Business Server installer will use port number 80 by default. If port 80 is 
already in use, you will need to specify another port number which is not in use.

■ Open a browser window on the server and enter this URL:
http://localhost:80 

■ If a non-error page is displayed, it means that a web server on that machine is 
already using port 80 — try the URL above with different port numbers until 
you find one that is not in use, then make a note of that port number for 
later reference. Do not use port numbers 8091 or 8099 — these will 
automatically be used by the M-Business Server.

3. Download the M-Business Server installer.

■ Open a browser and navigate to 
http://www.ianywhere.com/downloads/ 

■ Click the M-Business Anywhere Developer Edition link.

■ Fill in the form for the evaluation download and read the license agreement. 

■ Click the Agree and Submit button.

■ On the Download and Installation page, click the click here link in “To begin 
download process now, please click here” in the middle of the page.

■ On the M-Business Anywhere 6.0 for Windows Download page, click the 
Download button to the left of “M-Business Anywhere for Windows.”

■ Save the installer file, MBAnywhereW.exe, to a temporary location.

Note Your license number will be sent to you at the email address you supply in this 
step. You can start the installer immediately, but you will not be able to 
complete the installation until you have received your license number.

4. Run the M-Business Server installer.

■ Open the folder where you just saved the installer and double-click the 
MBAnywhereW.exe file to start the InstallShield Wizard.

■ After the Extracting Files panel completes, enter your server license number 
in the M-Business Anywhere Setup window that appears.

Get this from the email sent to the email address you gave in step 3 above.

http://www.ianywhere.com/downloads/index.html
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■ Accept the defaults on the rest of the panels until you reach the Sync Port 
panel. Here is the sequence you will see: 
- Server Functionality 
- Welcome 
- License Agreement 
- Choose Destination Location 
- Wireless Access SRP Key 
- User Friendly Server Name 
- Host Name 

The Sync Port panel is now displayed:

Figure 1-1                                           
Sync Port panel

Caution If port 80 is already in use on the target machine, enter another port number 
which is not in use on the Sync Port panel.

■ Clicke Next on the Sync Port panel to start the M-Business Anywhere setup 
process.

Note On the InstallShield Wizard Complete panel, you you can choose to restart 
your computer later, but you will not be able to continue with the steps that 
follow until you restart.

5. Verify that the installation was successful.

■ Restart the machine.

■ In a browser, navigate to http://localhost:8091.

If the M-Business Anywhere login page appears, the install was successful — 
continue. 
If the login page does not appear, start over with step 1 above.

After you have verified that the install was successful, go on with the next section, 
“Setting up a mobile device, test user, and test channel” (page 7).
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Setting up a mobile device, test user, and test channel

1. If the test device is an XP Tablet, proceed to step 3.

2. If the test device is Palm or Pocket PC, verify that the device is able to synchro-
nize with your desktop workstation. 

Palm devices sync via HotSync and Pocket PC devices sync via ActiveSync. Refer 
to the documentation that came with the device for detailed instructions. 

Once you have verified that the test device is able to synchronize, leave the 
device in its cradle.

Caution Do not proceed until you are able to synchronize your device.

3. Open the M-Business Server Administrator Console.

Navigate in your web browser to http://localhost:8091. 

Figure 1-2                                           
Download Client 
Software link on 
login screen

4. Click the New Account Registration link, at the top.

The Language Preference screen appears (“Step 1 of 7”).

5. Click the language that you want, then click Next.

The device Operating System screen appears (“Step 2 of 7”).

6. Click the device operating system that you want, then click Next.

The Download screen appears (“Step 3 of 7”).

7. Click the link, Click here to save the M-Business Client Software to your hard 
disk.

The File Download dialog appears.

8. Click Save to save the program to disk.

The Save As dialog appears.

9. Select a folder into which the program file will be saved, then click Save.

A Download dialog will show you the progress of the file transfer and display 
the message “Download Complete” when the file is copied into the folder you 
selected.

10. Click Open to start the InstallShield Wizard.

11. Follow the instructions on the screen to install M-Business Client on your desk-
top computer.
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12. Click OK when you see the screen display a message telling you that the M-Busi-
ness Client will be installed to your device the next time you synchronize.

Note M-Business Client also installs M-Business Connect on your desktop and mobile 
device. M-Business Connect enables M-Business Client to communicate with 
M-Business Server.

13. Return to your browser window where the Download screen (“Step 3 of 7”) is 
still displayed.

14. In the Download screen (“Step 3 of 7”) in your browser, click Next.

The Install screen (“Step 4 of 7”) appears.

15. If you ran the installer file by clicking the Open button in the Download dialog, 
you can ignore this screen and just click Next.

If you closed the Download dialog without running the installer file, follow the 
directions on the Install screen (“Step 4 of 7”) and click Next after you are 
finished.

The Register screen (“Step 5 of 7”) appears.

Figure 1-3                                           
Register screen

16. Enter your information in the Username, First Name, Last Name, Password, 
and Confirm Password fields.

If you do not want to re-enter your user name and password every time you 
access your account, select the Remember me checkbox.

17. Click Next.

The Configure screen (“Step 6 of 7”) appears. You should see a message saying 
that your account has been successfully added to the server. If you do not see 
this message, contact your system administrator.
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Figure 1-4                                           
Configure screen

18. In the Configure screen in your browser, click Configure Connection.

The Add M-Business Server dialog appears.

Figure 1-5                                           
Add Server dialog

19. Click Next, then follow the directions on the following screens to configure 
your mobile device’s connection to the server.

20. When you return to the Configure screen in your browser, click Next.

The Channel List for User... page appears. 
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Figure 1-6                                           
Create a Channel for 
User form

21. On the Create a Channel for User form, fill in these fields as follows:

■ for Title, enter Google Test 

■ for Location, enter http://www.google.com 

22. Click the View button to be sure the URL works.

23. Close the browser window opened by the View button.

24. If Google did not display, fix the URL and click the View button again.

25. Click the Create button at the bottom of the form to create the channel.



Administrator Guide for M-Business Anywhere Server, Version 6.0

iAnywhere Solutions, Inc. Page 11 of 14

Testing your device/user/channel setup

1. Sync your test device.

See the documentation that came with your device for instructions.

2. If your test device is not a Windows XP device, sync again.

On all platforms except Windows XP, the first sync simply installs the M-Business 
Client on the device. The second sync downloads the test channel content — 
the Google home page.

3. Start up the M-Business Client on the device.

Palm OS:
- tap the Applications silk-screen icon 

- tap the M-Business Client icon

Pocket PC OS:
- tap Start|Programs 
- tap the M-Business Client icon

Windows XP:
- tap or click Start|Programs 
- tap or click he M-Business Client icon

4. Make sure the device is offline.

Depending on your device and connection type, your device may be online 
after syncing. In order to see how the M-Business Client handles offline form 
submissions in the steps below, your test device must be offline:

Palm OS:
- tap the iAnywhere page title to open the menus
- on the Channels menu, tap Work Offline 

Pocket PC OS:
- tap the Tools menu, then tap Work Offline (if greyed out, device is already 
offline)

Windows XP:
- tap or click the File menu, then tap or click Work Offline 
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5. Under Personal Channels, tap the Google Test link to display your channel.

Figure 1-7                                           
Google Test link on 
device

6. Look in the Forms Manager.

Now that the test channel is properly synchronized to your device, we'll 
demonstrate a simple offline form submission. We’ll use the Forms Manager on 
the device to view an empty forms queue, a forms queue with pending forms, 
and finally the successful results of our form submission. First view the empty 
forms queue:

■ Palm OS - Tap the Google Search page title to open the menus, then on the 
Channels menu, tap Forms Manager.

■ Pocket PC OS - Tap the View menu at the lower left, then tap 
Forms Manager.

■ Windows XP - Tap the View menu at the top, then tap Forms Manager.

The Forms Manager opens, displaying a message beginning, “You have no 
pending form submissions...”

7. Perform a search.

■ Tap the Back button to return to the Google Search page.

■ Tap in the text field immediately above the Google Search button.

■ Type w3c as the search term.

■ Tap the Google Search button.

A message is displayed indicating that “your submission... will be sent during 
the next Synchronization.”

■ Tap OK to acknowledge the message and return to the Google Search page.

8. Perform another search.

■ Tap in the text field immediately above the Google Search button.

■ Type ieee as the search term.

■ Tap the Google Search button.

■ Tap OK to acknowledge the message.
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9. Look in the Forms Manager again.

■ Palm OS - Tap the Google Search page title to open the menus, then on the 
Channels menu, tap Forms Manager.

■ Pocket PC OS - Tap the View menu at the lower left, then tap 
Forms Manager.

■ Windows XP - Tap or click the View menu at the top, then tap 
Forms Manager.

The Forms Manager opens, this time displaying one entry for each search form 
you just submitted. The “pending” status indicates that these forms have been 
submitted offline on the device, but have not yet been submitted to the server 
in a sync.

10. Sync your test device.

There are several different ways to sync your device. In order to ensure that 
your device remains in offline mode, use the method listed below for your 
platform:

■ Palm OS - Sync the device through HotSync; see the documentation that 
came with the device for instructions.

■ Pocket PC OS - Sync the device through ActiveSync. Typically you just place 
the device in the cradle; see the documentation that came with the device 
for instructions.

■ Windows XP - In the M-Business Client on the device, tap or click the File 
menu at the top, then tap Sync.

When the sync is complete, the M-Business Client on the device automatically 
returns to its home page.

11. Look in the Forms Manager again.

■ Palm OS - Tap the Google Search page title to open the menus, then on the 
Channels menu, tap Forms Manager.

■ Pocket PC OS - Tap the View menu at the lower left, then tap 
Forms Manager.

■ Windows XP - Tap or click the View menu at the top, then tap 
Forms Manager.

The Forms Manager opens, still displaying one entry for each search form you 
submitted, but this time the “success” status indicates that these are the 
response forms returned by the server.

12. View your search results pages.

■ Tap the success link to display the search results for that form.

■ Tap the Back button to return to the Forms Manager to view the other 
search results page.

Note Tapping any link on one of your search results pages will get a “Page not 
available” message. If you get this message now, tap the Back button to return 
to the Forms Manager.
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Next steps

After the test/demo channel sync is successful, to create an application or mobilize 
an existing desktop web application, continue with the Introduction to M-Business 
Anywhere, “Mobile application design guidelines” chapter.
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