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About this guide

¢ “Purpose of this guide” on page vi

¢+  “What you need to continue” on page Vii
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About this guide

Purpose of this guide

This Developer Quick Start Guide for M-Business Anywhere, Version 6.5 is provided to help a developer
who is new to the M-Business Anywhere environment achieve the following objectives within 30-60
minutes:

¢

¢

¢

¢

¢

Install M-Business Server

Install M-Business Client on a mobile device

Set up a test user on M-Business Server

Set up a test channel on M-Business Server that will deliver web content to the mobile device

Synchronize the mobile device with M-Business Server to download and view the test channel content

When you are finished with this guide, you will be ready to concentrate on the design issues involved in
getting your target web content to work the way you want it to on the mobile devices that you must support.

Location of other M-Business Anywhere documentation

In order for the cross references to other M-Business Anywhere documents to work properly as clickable
links, all of the M-Business Anywhere documentation PDF files must be located in the same directory.

¢ Downloading the complete set of M-Business Anywhere documentation

1.

2.

You may download the complete set of M-Business Anywhere documentation from:
http://www.ianywhere.com/developer/product_manuals/mbusiness_anywhere/

Under "Current Version”, click the Complete doc set link, then unzip the files into one directory.

Vi
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What you need to continue

What you need to continue

¢ Checking the system requirements

1.

Make sure you have a workstation set up to use for testing.

This workstation may be the same host machine on which M-Business Server will be installed, or any
other workstation that can connect to the host over a network.

Operating system - The workstation must have one of the following versions of Microsoft Windows:

¢ O98SE
+ 2000 Professional with Service Pack 4
+ XP Professional

¢ XP Home
Browser - The workstation must have one of the following supported browsers:

¢ Internet Explorer 5.5
¢ Internet Explorer 6.0

¢ Firefox 1.x

Note
You will need to log in as an administrator on the workstation in order to install the M-Business Client
software.

Make sure you have a mobile device set up to use for testing.

You need to have a mobile device with a cradle attached to the workstation from which you will access
the M-Business Server Administrator Console and synchronize the device. If you are using a Windows
XP workstation, the workstation itself can serve as the test device.

Palm requirements - Palm OS devices running version 4.x or 5.x of Palm OS 2 MB free memory.

Windows Mobile Pocket PC requirements - Windows Mobile Pocket PC devices, including Pocket PC
and Handheld PC devices, running version 3.0 and using ARM processors with 2 MB free memory.

Windows XP requirements - Windows XP Tablet Edition, or Windows XP Professional.

Windows Mobile 5 requirements - Windows Mobile 5 devices, including Windows Mobile and Handheld
PC devices, running version 3.0 or Windows Mobile 5 with 2 MB free memory.

Microsoft Smartphone requirements - Microsoft Smartphone devices running Windows Mobile 5 or
Windows Mobile 2003 with 2 MB free memory.
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About this guide

Note

Before proceeding, the device should already be set up to synchronize at your desktop workstation.
Palm devices synchronize via HotSync, Windows Mobile 5 and Windows Mobile Pocket PC devices
synchronize via ActiveSync, Windows XP devices synchronize directly via a network connection, and
Microsoft Smartphone devices synchronize directly via the wireless phone connection. If you have just
received a new device, refer to the documentation that came with it to set it up correctly.

Make sure the Windows server on which you plan to install M-Business Server meets the following
hardware and software requirements:

¢+ 2GBRAM

¢ Pentium 4 2.5 GHz or better CPU

¢ One of the following operating systems:
¢ Windows 2000 Server with Service Pack 4
¢ Windows 2003 Server with Service Pack 1

Make sure you have the admin user login information for the target server.

viii
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Developer Quick Start Guide

Installing M-Business Server on Windows

Note

If you are upgrading an existing M-Business Anywhere installation, or installing on a Unix platform, this
guide does not cover those situations. See the Administrator Guide for M-Business Anywhere Server for
instructions. See “Location of other M-Business Anywhere documentation” on page vi for instructions on
downloading this guide.

Follow the instructions below to perform a new installation of M-Business Server on a Windows machine.
If you need more details on any of the steps, see “Upgrading and installing M-Business Server” [M-Business
Anywhere Administrator Guide]. If this link does not work, see “Location of other M-Business Anywhere
documentation” on page vi for instructions on downloading this guide.

¢ Preforming a new installation of M-Business Server on a Windows machine

1. On the target server, log in to Windows as an administrator.

2. Determine the port numbers that are already in use on the machine.

Note
The M-Business Server installer will use port number 80 by default. If port 80 is already in use, you
will need to specify another port number which is not in use.

¢

Open a browser window on the server and enter this URL:

http://localhost:80

If a non-error page is displayed, it means that a web server on that machine is already using port 80
— try the URL above with different port numbers until you find one that is not in use, then make
a note of that port number for later reference. Do not use port numbers 8091 or 8099 — these will
automatically be used by M-Business Server.

3.  Download the M-Business Server installer.

¢

Open a browser and navigate to:

http://www.ianywhere.com/downloads/

Click the M-Business Anywhere Developer Edition link.

Fill in the form for the evaluation download and read the license agreement.
Click the Agree and Submit button.

On the Download and Installation page, click the click here link in "To Begin Download Process
Now, Please Click Here" in the middle of the page.
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Installing M-Business Server on Windows

¢ On the M-Business Anywhere 6.5 for Windows Download page, click the Download button to the
left of "M-Business Anywhere for Windows".

¢ Save the installer file, MBAnywhereW.exe, to a temporary location.

Note

Your license number will be sent to you at the email address you supply in this step. You can start the
installer immediately, but you will not be able to complete the installation until you have received your
license number.

Run the M-Business Server installer.

¢ Open the folder where you just saved the installer and double-click the MBAnywhereW.exe file to
start the InstallShield Wizard.

Very quickly the Welcome panel appears.

¢+ Click Next.

The Server License panel appears.

¢ Enter your server license number in the Server License panel.

Get this from the email sent to the email address you gave in step 3 above.

¢ Accept the defaults on the next four panels until you reach the Sync Port panel. Here is the sequence
you will see:

¢ Server Functionality
¢ License Agreement
¢ Choose Destination Location

¢ User Friendly Server Name

The Sync Port panel is now displayed.

¢ Enter a port number which is not in use on this machine.

Caution
If port 80 is already in use on the target machine, enter another port number which is not in use on
the Sync Port panel.

¢ Click Next.

The Ul Port panel appears.

¢ Enter portnumbers which are no in use on this machine for the next three panels. Here is the sequence
you will see:
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¢ Ul Port
¢ Database Port

¢ Soap Server Port

Caution
If any of the default port numbers are already in use on the target machine, enter another port number
which is not in use.

The Host Name panel is now displayed.

¢ Click Next on the Host Name panel to start the M-Business Anywhere Setup process.

Note
On the InstallShield Wizard Complete panel, you can choose to restart your computer later, but you
will not be able to continue with the steps that follow until you restart.

5. Verify that the installation was successful.

¢ Restart the machine.

¢ Inabrowser, navigate to http://localhost:8091.

If the M-Business Anywhere login page appears, the install was successful — continue. If the login
page does not appear, start over with step 1 above.

After you have verified that the install was successful, go on with the next section, “Setting up a mobile
device, test user, and test channel” on page 5.
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Setting up a mobile device, test user, and test channel

Setting up a mobile device, test user, and test channel

¢ Setting up a mobile device, test user, and test channel

1. If the test device is an XP Tablet, proceed to step 3.

2. If the test device is a different Microsoft OS device, or a Palm device, verify that the device is able to
synchronize with your desktop workstation.

Palm devices synchronize via HotSync and Microsoft OS devices synchronize via ActiveSync. Refer
to the documentation that came with the device for detailed instructions.

Once you have verified that the test device is able to synchronize, leave the device in its cradle.

Caution
Do not proceed until you are able to synchronize your device.

3. Open the M-Business Server Administrator Console.

Navigate in your web browser to http://localhost:8091.

Anywhere. M-BUSINESS ANYWHERE 4
Mew Account I—
Registration User Marme |
; ; Password |
Yiew User Guide I Remember Me
Downlaad Client

Software

@1997-2005 iAnywhere Solutions, a subsidiary of Sybase, Inc.

4. Click the New Account Registration link, at the top.
The language preference screen appears (Step 1 of 7).
5.  Click the language that you want, then click Next.
The device operating system screen appears (Step 2 of 7).

6. Click the device operating system that you want.

¢ PalmOS — for any Palm OS device (not for Palm-branded devices running a Microsoft OS)

¢ Pocket PC — for non-phone devices with "Pocket PC" in the branding, including Windows Mobile 5
devices (the installer automatically detects older Pocket PC vs. newer Windows Mobile 5 Pocket
PC and installs the correct version)

¢ PPC-Smartphone — for Microsoft Smartphone devices (does not work with other "Smartphone"
devices that do not have Microsoft in the branding)

Copyright © 2007, iAnywhere Solutions, Inc. 5
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10.

11.

12.
13.

14.
15.

16.

¢ Windows — for any device with a Windows XP operating system, for example, Tablet PCs and
laptops

Click Next.

The download screen appears (Step 3 of 7).

Click the link, Click here to save the M-Business Client Software to your hard disk.
The File Download dialog appears.

Click Save to save the program to disk.

The Save As dialog appears.

Select a folder into which the program file will be saved, then click Save.

A Download dialog will show you the progress of the file transfer and display the message Download
Complete when the file is copied into the folder you selected.

Click Open to start the InstallShield Wizard.

Note

If you have a secure digital (SD) card installed on your device, it will be detected by the M-Business
Anywhere installer. For information on the options available when an SD card is detected, see
“Installing M-Business Client to use a secure digital (SD) card on your Microsoft OS device” [M-
Business Anywhere Client User Guide].

Follow the instructions on the screen to install M-Business Client on your desktop computer.

Click OK when you see the screen display a message telling you that M-Business Client will be installed
to your device the next time you synchronize.

Note
M-Business Client also installs M-Business Connect on your desktop and mobile device. M-Business
Connect enables M-Business Client to communicate with M-Business Server.

Return to your browser window where the download screen (Step 3 of 7) is still displayed.
In the download screen (Step 3 of 7) in your browser, click Next.
The Install screen (Step 4 of 7) appears.

If you ran the installer file by clicking the Open button in the Download dialog, you can ignore this
screen and just click Next.

If you closed the Download dialog without running the installer file, follow the directions on the install
screen (Step 4 of 7) and click Next after you are finished.

The register screen (Step 5 of 7) appears.
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Setting up a mobile device, test user, and test channel

17.

18.

19.

Anywhere. M-BUSINESS ANYWHERE ‘=

Mew Account Registration

Cancel | Flease create a User account.  Checking "Remember Me" will allow you to
access your M-Business Enterprise settings without logging in first. Step =
of 7.
User Name |
First Name |
Last Marne |
Password |

Confirm Password |

[ Remember Me

©1997-2005 iAnywhere Solutions, a subsidiary of Sybase, Inc.

Enter your information in the Username, First Name, Last Name, Password, and Confirm Password fields.

If you do not want to re-enter your user name and password every time you access your account, select
the Remember me checkbox.

Click Next.

The configure screen (Step 6 of 7) appears. You should see a message saying that your account has
been successfully added to the server. If you do not see this message, contact your system administrator.

Anywhere. M-BUSINESS ANYWHERE g

Mew Account Registration

cancel | Your account has been successfully created.  Flease click the link below to
configure your device to connect to this server. Step & of 7.

Configure Connection

©1997-2005 iAnywhere Solutions, a subsidiary of Sybase, Inc.

In the configure screen in your browser, click Configure Connection.

The Add M-Business Serverdialog appears.

Copyright © 2007, iAnywhere Solutions, Inc. 7



Developer Quick Start Guide

I'Y Add M-Business Server x|

Connection Advyisany

Prezs Mest ta configure vour handheld device profile ta
connect to the fallawing server.

Server name: M-Buzinezs Anpwhere
Server address: bully: 30

Prezs Cancel if you do not want to add this server.

Caution: “r'ou should press Mext only if pou truzt the source
making the request to add thiz zerver bo vour handheld device

profile.
Tell e mare. .. |
¢ Back I M et = I Caricel |

20. Click Next, then follow the directions on the following screens to configure your mobile device's
connection to the server.

21. When you return to the configure screen in your browser, click Next.

The Create a Channel for User... page appears.
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Setting up a mobile device, test user, and test channel

22.

23.
24.
25.
26.

Anywhere. M-BUSINESS ANYWHERE 3
Channel List

Create Channel
Yiew Sync Log
Public Channels

Create a Channel for User: psmith

Optional Groups Location |http:,!,! Wiew |
Settings

e e Channel Size Limit [5S00 KB

Yiew User Guide Clil (Bl ID_

Download Client Include Images =
Software i
Lagout Color Depth |Automatic =]
Follow ©ffsite Links I
sync only

Refresh © Only Once
® Every Sync
©only once every |6 hours(sy T only on weekdays

© Daily
|12 ‘I:IDD 'l oo O PM
on days:

¥ Monday W Tuesday W wWednesday W Thursday
IV Friday W Zaturday W Sunday

Reset |

Create a new User Channel by editing the fields abowve and clicking Create. (Title and
Location are required.’

©1997-2008 idnywhere Solutions, a subsidiary of Sybase, Ine.

—

On the Create a Channel for User form, fill in these fields as follows:

+ for Title, enter Google Test

¢ for Location, enter http://www.google.com

Click the View button to be sure the URL works.

Close the browser window opened by the View button.

If Google did not display, fix the URL and click the View button again.

Click the Create button at the bottom of the form to create the channel.
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Testing your device/user/channel setup

¢ Testing your device/user/channel setup

1.

Synchronize your test device.
See the documentation that came with your device for instructions.
If your test device is not a Windows XP device, synchronize again.

On all platforms except Windows XP, the first synchronization simply installs M-Business Client on
the device. The second synchronization downloads the test channel content — the Google home page.

Start up M-Business Client on the device.

Palm OS devices:

¢ tap the Applications silk-screen icon

@

lon

¢ tap the M-Business Client icon

i

M-Business

Windows Mobile Pocket PC devices:

¢ tap Start»Programs

¢ tap the M-Business Client icon

Windows XP devices:

¢ tap or click Start»Programs

¢ tap or click the M-Business Client icon

Windows Mobile 5 or Microsoft Smartphone devices:

10
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Testing your device/user/channel setup

4.

¢ choose Start»M-Business Client
Make sure the device is offline.

Depending on your device and connection type, your device may be online after synchronizing. In order
to see how M-Business Client handles offline form submissions in the steps below, your test device
must be offline:

Palm OS devices:

¢ tap the iAnywhere page title to open the menus

¢ on the Channels menu, tap Work Offline

Windows Mobile Pocket PC devices:

¢ tap the Tools menu, then tap Work Offline (if greyed out, device is already offline)
Windows XP devices:

¢ tap or click the File menu, then tap or click Work Offline

Windows Mobile 5 or Microsoft Smartphone devices:

¢ choose Menu»Work Offline

Under Personal Channels, tap the Google Test link to display your channel.

[iAnywhere| =2
[Form=] [ZERVERE] [ROD]| [REMOLE]

Personal Channels
B Google Test

Look in the Forms Manager.

Now that the test channel is properly synchronized to your device, we'll demonstrate a simple offline
form submission. We'll use the Forms Manager on the device to view an empty forms queue, a forms
queue with pending forms, and finally the successful results of our form submission. First view the
empty forms queue:

¢ Palm OS devices - tap the Google Search page title to open the menus, then on the Channels menu,
tap Forms Manager.

¢ Windows Mobile Pocket PC devices - tap the View menu at the lower left, then tap Forms Manager.

Copyright © 2007, iAnywhere Solutions, Inc. 11



Developer Quick Start Guide

10.

¢ Windows XP devices - click or tap the View menu at the top, then tap Forms Manager.

¢ Windows Mobile 5 or Microsoft Smartphone devices - choose View»Forms Manager.

The Forms Manager opens, displaying a message beginning, "You have no pending form
submissions...".

Perform a search.

¢ Tap the Back button to return to the Google Search page.
¢ Tap in the text field immediately above the Google Search button.
¢ Type w3c as the search term.

¢ Tap the Google Search button.
A message is displayed indicating that your submission... will be sent during the next synchronization.

¢ Tap OK to acknowledge the message and return to the Google Search page.

Perform another search.

¢ Tap in the text field immediately above the Google Search button.
¢ Type ieee as the search term.

¢ Tap the Google Search button.

¢ Tap OK to acknowledge the message.

Look in the Forms Manager again.

¢ Palm OS devices - tap the Google Search page title to open the menus, then on the Channels menu,
tap Forms Manager.

¢ Windows Mobile Pocket PC devices - tap the View menu at the lower left, then tap Forms Manager.
¢ Windows XP devices - tap or click the View menu at the top, then tap Forms Manager.

¢ Windows Mobile 5 or Microsoft Smartphone devices - choose View»Forms Manager.

The Forms Manager opens, this time displaying one entry for each search form you just submitted. The
pending status indicates that these forms have been submitted offline on the device, but have not yet
been submitted to the server in a synchronization.

Synchronize your test device.

There are several different ways to synchronize your device. In order to ensure that your device remains
in offline mode, use the method listed below for your platform:

¢ Palm OS devices - synchronize the device through HotSync; see the documentation that came with
the device for instructions.

12
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Testing your device/user/channel setup

¢ Windows Mobile 5 or Windows Mobile Pocket PC devices - synchronize the device through
ActiveSync. Typically you just place the device in the cradle; see the documentation that came with
the device for instructions.

¢ Windows XP devices - in M-Business Client on the device, tap or click the File menu at the top, then
tap Sync.

¢ Microsoft Smartphone devices - in M-Business Client on the device, choose Menu»Sync All.

When the synchronization is complete, M-Business Client on the device automatically returns to its
home page.

11. Look in the Forms Manager again.

¢ Palm OS devices - tap the Google Search page title to open the menus, then on the Channels menu,
tap Forms Manager.

¢ Windows Mobile Pocket PC devices - tap the View menu at the lower left, then tap Forms Manager.
¢ Windows XP devices - tap or click the View menu at the top, then tap Forms Manager.

¢ Windows Mobile 5 or Microsoft Smartphone devices - choose View»Forms Manager.

The Forms Manager opens, still displaying one entry for each search form you submitted, but this time
the success status indicates that these are the response forms returned by the server.

12. View your search results pages.

¢ Tap the success link to display the search results for that form.

¢ Tap the Back button to return to the Forms Manager to view the other search results page.

Note
Tapping any link on one of your search results pages will get a Page Not Available message. If you get
this message now, tap the Back button to return to the Forms Manager.
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Next steps

After the Google Test channel synchronization is successful, to create an application or mobilize an existing
desktop web application, continue with “Mobile application design guidelines” [Introduction to M-Business
Anywhere]. If this link does not work, see “Location of other M-Business Anywhere

documentation” on page vi for instructions on downloading this guide.
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