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About this Guide

Purpose of this guide

This Developer Quick Start Guide for M-Business Anywhere, Version 7.0 is provided to help a developer
who is new to the M-Business Anywhere™ environment achieve the following objectives within 30 — 60
minutes:

Install M-Business Server

Install M-Business Client on a mobile device

Set up a test user on M-Business Server

Set up a test channel on M-Business Server that will deliver Web content to the mobile device

Synchronize the mobile device with M-Business Server to download and view the test channel content

When you are finished with this guide, you will be ready to concentrate on the design issues involved in
getting your target Web content to work the way you want it to on the mobile devices that you must support.

The M-Business Anywhere documentation set

In addition to this document, there are several other iAnywhere Solutions publications available that you
may find useful in setting up and using M-Business Server. The complete M-Business Anywhere
documentation set is listed below.

To

o &~ w DN

Release Bulletin for M-Business Anywhere

New Features Bulletin for M-Business Anywhere
M-Business Anywhere, an Introduction

Installation Guide for M-Business Anywhere Server
Administrator Guide for M-Business Anywhere Server
User Guide for M-Business Anywhere Client
Developer Quick Start Guide for M-Business Anywhere
Application Developer Guide for M-Business Anywhere
API Reference for M-Business Anywhere

access the complete M-Business Anywhere documentation set

Navigate to http://sybooks.sybase.com.

Select M-Business Anywhere as the product, and English as the language, then click Go.
Click the Document Set link for M-Business Anywhere 7.0.

Click the View Entire Collection link.

In the Contents list, under the M-Business Anywhere 7.0 heading, select the document you wish to
view.

Vi
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http://sybooks.sybase.com

Purpose of this guide

. To view the HTML version of a document, click the Start reading HTML link.

. To view the PDF version of a document, click the View this... as PDF link.

Note

For links between different PDF files to work correctly, you must download all the PDF files into the
same local directory.
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About this Guide

What you need to continue

To check the system requirements

1. Make sure you have a workstation set up to use for testing.

This workstation may be the same host machine on which M-Business Server will be installed, or any
other workstation that can connect to the host over a network.

Operating system — The workstation must have one of the following versions of Microsoft Windows:
e Windows 2000 Professional with Service Pack 4

e Windows XP Professional with Service Pack 1 or 2

e Windows Vista with Service Pack 1

e Windows Vista Tablet with Service Pack 1

Browser — The workstation must have one of the following supported browsers:

e Microsoft Internet Explorer 5.5 or 6.0 or 7.0

e Mozilla Firefox 2.0

Note
You will need to log in as an administrator on the workstation to install the M-Business Client software.

Make sure you have a mobile device set up to use for testing.

You need to have a mobile device with a cradle attached to the workstation from which you will access
the M-Business Server Administrator Console and synchronize the device. If you are using a Windows
XP workstation, the workstation itself can serve as the test device.

Palm OS requirements — Palm OS devices running version 4.x or 5.x of Palm OS 2 MB free memory.

Windows Mobile Pocket PC 2003 requirements—Windows Mobile Pocket PC 2003 devices, including
Pocket PC and Handheld PC devices, running version 3.0 and using ARM processors with 2 MB free
memory.

Win32 requirements — Windows XP Tablet Edition, Windows XP Professional, or Windows Vista.

Windows Mobile 5 or 6 requirements — Windows Mobile 5 or 6 devices, including Windows Mobile
and Handheld PC devices, running version 3.0 or Windows Maobile 5 or 6 with 2 MB free memory.

Microsoft Smartphone requirements — Microsoft Smartphone devices running Windows Mobile 5 or
6, or Windows Mobile Pocket PC 2003 with 2 MB free memory.

viii
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What you need to continue

Note
Before proceeding, the device should already be set up to synchronize at your desktop workstation.

Palm OS devices synchronize through HotSync. Win32 devices synchronize directly through a network
connection. Microsoft Smartphone device synchronize directly through the wireless phone connection.

Other Microsoft OS devices synchronize through ActiveSync on Windows versions prior to Windows
Vista. Windows Vista replaces ActiveSync with Mobile Device Center (MDC).

If you want to use a If you have just received a new device, refer to the documentation that came with
it to set it up correctly.

Make sure the Windows server on which you plan to install M-Business Server meets the following
hardware and software requirements:

e 2GBRAM

e Pentium 4 2.5 GHz or better CPU

e One of the following operating systems:
o Windows 2000 Server with Service Pack 4
o Windows 2003 Server with Service Pack 2

Make sure you have the admin user login information for the target server.
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Developer Quick Start Guide

Installing M-Business Server on Windows

Note

If you are upgrading an existing M-Business Anywhere installation, or installing on a UNIX platform, this
guide does not cover those situations. See the Installation Guide for M-Business Anywhere Server for
instructions. See “The M-Business Anywhere documentation set” on page vi for instructions on downloading
this guide.

Follow the instructions below to perform a new installation of M-Business Server on a Windows machine.
If you need more details on any of the steps, see “Upgrading and Installing M-Business Server” [M-Business
Anywhere Installation Guide]. If this link does not work, see “The M-Business Anywhere documentation
set” on page vi for instructions on downloading this guide.

To perform a new installation of M-Business Server on a Windows machine

1. On the target server, log in to Windows as an administrator.

2. Determine the port numbers that are already in use on the machine.

Note
The M-Business Server installer will use port number 80 by default. If port 80 is already in use, you will
need to specify another port number which is not in use.

Open a browser window on the server and enter this URL:
http://localhost:80

If a non-error page is displayed, it means that a Web server on that machine is already using port 80
—try the URL above with different port numbers until you find one that is not in use, then make a
note of that port number for later reference. Do not use port numbers 8091 or 8099—these will
automatically be used by M-Business Server.

3. Download the M-Business Server installer.

Open a browser and navigate to:

http://www.ianywhere.com/downloads/

Click the M-Business Anywhere Developer Edition link.

Fill in the form for the evaluation download and read the license agreement.
Click the Agree and Submit button.

On the Download and Installation page, click the click here link in "To Begin Download Process
Now, Please Click Here" in the middle of the page.

On the M-Business Anywhere 7.0 for Windows Download page, click the Download button to the
left of "M-Business Anywhere for Windows".

Save the installer file, MBAnywhereW.exe, to a temporary location.
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http://localhost:80
http://www.ianywhere.com/downloads/index.html

Installing M-Business Server on Windows

Note

Your license number will be sent to you at the e-mail address you supply in this step. You can start the
installer immediately, but you will not be able to complete the installation until you have received your
license number.

4, Run the M-Business Server installer.

Open the folder where you just saved the installer and double-click the MBAnywhereW.exe file to
start the InstallShield Wizard.

Very quickly the Welcome panel appears.

Click Next.

The Server License panel appears.

Enter your server license key in the Server License panel.

Get this from the e-mail message sent to the e-mail address you gave in step 3 above.

Accept the defaults on the next five panels until you reach the Sync Port panel. Here is the sequence
you will see:

o Server Functionality

o License Agreement

o Choose Destination Location

o User Friendly Server Name

o Host Name

The Sync Port panel is now displayed.

Enter a port number which is not in use on this machine.

Caution
If port 80 is already in use on the target machine, enter another port number which is not in use on
the Sync Port panel.

Click Next.
The Ul Port panel appears.

Enter port numbers which are not in use on this machine for the next three panels. Here is the sequence
you will see:

o Ul Port
o Database Port
o SOAP Server Port

Caution
If any of the default port numbers are already in use on the target machine, enter another port number
which is not in use.
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Developer Quick Start Guide

e Click Next on the SOAP Server Port panel to start the M-Business Anywhere Setup process.

Note
On the InstallShield Wizard Complete panel, you can choose to restart your computer later, but you
will not be able to continue with the steps that follow until you restart.

5. Verify that the installation was successful.
e Restart the machine.
e In abrowser, navigate to http://localhost:8091.
If the M-Business Anywhere login page appears, the install was successful—continue. If the login
page does not appear, start over with step 1 above.

After you have verified that the install was successful, go on with the next section, “Setting up a mobile
device, test user, and test channel” on page 5.

4 Copyright © 2008, iAnywhere Solutions, Inc.



Setting up a mobile device, test user, and test channel

Setting up amobile device, test user, and test channel

Setting up a mobile device, test user, and test channel

1. If the test device is a Windows XP Tablet, proceed to step 3.

2. If the test device is a different Microsoft OS device, or a Palm device, verify that the device is able to
synchronize with your desktop workstation.

Palm devices synchronize through HotSync and Microsoft OS devices synchronize through ActiveSync.
Refer to the documentation that came with the device for detailed instructions.

Once you have verified that the test device is able to synchronize, leave the device in its cradle.

Caution
Do not proceed until you are able to synchronize your device.

3. Open the M-Business Server Administrator Console.

Navigate in your Web browser to http://localhost:8091.

Anywhere. M-BUSINESS ANYWHERE =
Mew Account User Mame ||—
Registration
Password|
Documentation I Remember Me
Download Client

Software

©1997-2008 iAnywhere Solutions, a subsidiary of Syhase, Inc.

4. Click the New Account Registration link, at the top.
The language preference screen appears (Step 1 of 7).
5. Click the language that you want, then click Next.
The device operating system screen appears (Step 2 of 7).
6. Click the device operating system that you want.
e PalmOS - for any Palm OS device (not for Palm-branded devices running a Microsoft OS)

e Pocket PC — for non-phone devices with "Pocket PC" in the branding, including Windows Mobile
5 and 6 devices (the installer automatically detects older Pocket PC vs. newer Windows Mobile 5 or
6 Pocket PC and installs the correct version)

e PPC-Smartphone - for Microsoft Smartphone devices (does not work with other "Smartphone™
devices that do not have Microsoft in the branding)

e \Windows — for any device with a Win32 operating system, for example, Tablet PCs and laptops
7. Click Next.

The download screen appears (Step 3 of 7).

Copyright © 2008, iAnywhere Solutions, Inc. 5



Developer Quick Start Guide

10.

11.

12.
13.

14.
15.

16.

Click the link, Click here to save the M-Business Client Software to your hard disk.
The File Download dialog appears.

Click Save to save the program to disk.

The Save As dialog appears.

Select a folder into which the program file will be saved, then click Save.

A Download dialog will show you the progress of the file transfer and display the message Download
Complete when the file is copied into the folder you selected.

Click Open to start the InstallShield Wizard.

Note

If you have a secure digital (SD) card installed on your device, it will be detected by the M-Business
Anywhere installer. For information on the options available when an SD card is detected, see “Installing
M-Business Client to use a secure digital (SD) card on your Microsoft OS device” [M-Business Anywhere
Client User Guide].

Follow the instructions on the screen to install M-Business Client on your desktop computer.

Click OK when you see the screen display a message telling you that M-Business Client will be installed
to your device the next time you synchronize.

Note
M-Business Client also installs M-Business Connect on your desktop and mobile device. M-Business
Connect enables M-Business Client to communicate with M-Business Server.

Return to your browser window where the download screen (Step 3 of 7) is still displayed.
In the download screen (Step 3 of 7) in your browser, click Next.
The Install screen (Step 4 of 7) appears.

If you ran the installer file by clicking the Open button in the Download dialog, you can ignore this screen
and just click Next.

If you closed the Download dialog without running the installer file, follow the directions on the install
screen (Step 4 of 7) and click Next after you are finished.

The register screen (Step 5 of 7) appears.

Copyright © 2008, iAnywhere Solutions, Inc.




Setting up a mobile device, test user, and test channel

Anywhere.

M-BUSINESS ANYWHERE i

Cancel |

Mew Account Registration

Flease create a User account. Checking "Remember Me" will allow you to
access your M-Business Enterprise settings without logging in first. Step S
of 7.

User Name |

First Name |

Last MNarne |

Password |

Confirm Password |

[ Remember Me

©1997-2008 isnywhere Solutions, a subsidiary of Sybase, Inc.

17. Enter your information in the Username, First Name, Last Name, Password, and Confirm
Password fields.

If you do not want to reenter your user name and password every time you access your account, select
the Remember me checkbox.

18. Click Next.

The configure screen (Step 6 of 7) appears. You should see a message saying that your account has been
successfully added to the server. If you do not see this message, contact your system administrator.

Anywhere.

M-BUSINESS ANYWHERE "

Cancel |

Mew Account Registration

Your account has been successfully created.  Flease click the link below to
configure your device to connect to this server. Step & of 7.

Configure Connection

©1997-2008 iAnywhere Solutions, a subsidiary of Sybase, Inc.

_

19. In the configure screen in your browser, click Configure Connection.

The Add M-Business Serverdialog appears.
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I Add M-Business Server x|

Connection Advisary

Prezs Mest ta configure vour handheld device profile ta
cohnect to the following server.

Server name: M-Buziness Arpwhere
Server address: bully: 30

Prezs Cancel if you do not want to add thiz zerver.

Caution: *vou zhould pregs Mext anly if pou tuzt the zounze
making the request to add thiz zerver bo vour handheld device

profile.
Tell me mare. . |
¢ Back I MHext = I Cancel |

20. Click Next, then follow the directions on the following screens to configure your mobile device's
connection to the server.

21. When you return to the configure screen in your browser, click Next.

The Create a Channel for User... page appears.

8 Copyright © 2008, iAnywhere Solutions, Inc.



Setting up a mobile device, test user, and test channel

Anywhere.

M-BUSINESS ANYWHERE 5

Zhannel List
Create Channel
Yiew Sync Log
Public Channels
Optional Groups
Settings

Create a Channel for User: psmith

Title |NISEEE.

Location |http://

Wiew |

Channel Size Limit |S00 KB

0] tati
acumentation Link Depth ID_

Download Client

Software Include Images M
Logout
Color Depth |Automatic =]
Follow Offsite Links T
sync only T

Refresh © Only Once
® Every Sync
Conly once every IE_ hours(s) T only on weekdays
 Daily

|12 vI :IDD vI = oan O PM

on days:
V¥ Monday W Tuesday
v Friday

Reset |

Create a new User Channel by editing the fields abowve and clicking Create. (Title and
Location are required.)

¥ wednesday
W Saturday W Sunday

¥ Thursday

©1997-2003 idnywhere Solutions, a subsidiary of Sybase, Inc.

—

22. On the Create a Channel for User form, fill in these fields as follows:
e for Title, enter Google Test
e for Location, enter http://www.google.com

23. Click the View button to be sure the URL works.

24. Close the browser window opened by the View button.

25. If Google did not display, fix the URL and click the View button again.

26. Click the Create button at the bottom of the form to create the channel.

Copyright © 2008, iAnywhere Solutions, Inc. 9
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Testing your device/user/channel setup

Testing your device/user/channel setup

1. Synchronize your test device.
See the documentation that came with your device for instructions.
2. If your test device is not a Win32 device, synchronize again.

On all platforms except Win32, the first synchronization simply installs M-Business Client on the device.
The second synchronization downloads the test channel content—the Google home page.

3. Start up M-Business Client on the device.
Palm OS devices:
e tap the Applications silk-screen icon

@

len

e tap the M-Business Client icon

4

M-Business

Windows Mobile Pocket PC 2003 devices:
e tap Start » Programs
e tap the M-Business Client icon

Win32 devices:
e tap or click Start » Programs
e tap or click the M-Business Client icon

Windows Mobile 5 or 6 or Microsoft Smartphone devices:
e choose Start » M-Business Client

4. Make sure the device is offline.

10
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Testing your device/user/channel setup

Depending on your device and connection type, your device may be online after synchronizing. To see
how M-Business Client handles offline form submissions in the steps below, your test device must be
offline:

Palm OS devices:

e tap the iIAnywhere page title to open the menus

e on the Channels menu, tap Work Offline

Windows Mobile Pocket PC devices:

e tap the Tools menu, then tap Work Offline (if greyed out, device is already offline)
Win32 devices:

e tap or click the File menu, then tap or click Work Offline

Windows Mobile 5 or 6 or Microsoft Smartphone devices:

e choose Menu » Work Offline

5. Under Personal Channels, tap the Google Test link to display your channel.

[iAnywhere| 2
[Form=]| [ZErvERE]| [ADD]| [REMOVE]

Personal Channels
B Google Test

6. Look in the Forms Manager.

Now that the test channel is properly synchronized to your device, we'll demonstrate a simple offline
form submission. We'll use the Forms Manager on the device to view an empty forms queue, a forms
gueue with pending forms, and finally the successful results of our form submission. First view the empty
forms queue:

e Palm OS devices —tap the Google Search page title to open the menus, then on the Channels menu,
tap Forms Manager.

e Windows Mobile Pocket PC 2003 devices — tap the View menu at the lower-left, then tap Forms
Manager.

e Win32 devices — click or tap the View menu at the top, then tap Forms Manager.

e Windows Mobile 5 or 6 or Microsoft Smartphone devices — choose View » Forms Manager.

The Forms Manager opens, displaying a message beginning, 'Y ou have no pending form submissions...".
7. Perform a search.

e Tap the Back button to return to the Google Search page.

Copyright © 2008, iAnywhere Solutions, Inc. 11
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10.

11.

e Tap in the text field immediately above the Google Search button.

e Type w3c as the search term.

e Tap the Google Search button.

A message is displayed indicating that your submission... will be sent during the next synchronization.
e Tap OK to acknowledge the message and return to the Google Search page.
Perform another search.

e Tap in the text field immediately above the Google Search button.

e Type ieee as the search term.

e Tap the Google Search button.

e Tap OK to acknowledge the message.

Look in the Forms Manager again.

e Palm OS devices —tap the Google Search page title to open the menus, then on the Channels menu,
tap Forms Manager.

e \Windows Mobile Pocket PC 2003 devices — tap the View menu at the lower-left, then tap Forms
Manager.

e \Win32 devices — tap or click the View menu at the top, then tap Forms Manager.
e \Windows Mobile 5 or 6 or Microsoft Smartphone devices — choose View » Forms Manager.

The Forms Manager opens, this time displaying one entry for each search form you just submitted. The
pending status indicates that these forms have been submitted offline on the device, but have not yet
been submitted to the server in a synchronization.

Synchronize your test device.

There are several different ways to synchronize your device. To ensure that your device remains in offline
mode, use the method listed below for your platform:

e Palm OS devices — synchronize the device through HotSync; see the documentation that came with
the device for instructions.

e \Windows Mobile 5 or 6 or Windows Mobile Pocket PC 2003 devices — synchronize the device
through ActiveSync. Typically you just place the device in the cradle; see the documentation that
came with the device for instructions.

e \Win32 devices — in M-Business Client on the device, tap or click the File menu at the top, then tap
Sync.

e Microsoft Smartphone devices — in M-Business Client on the device, choose Menu » Sync All.

When the synchronization is complete, M-Business Client on the device automatically returns to its home
page.
Look in the Forms Manager again.

e Palm OS devices —tap the Google Search page title to open the menus, then on the Channels menu,
tap Forms Manager.

12
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Testing your device/user/channel setup

e \Windows Mobile Pocket PC 2003 devices — tap the View menu at the lower-left, then tap Forms
Manager.

e \Win32 devices — tap or click the View menu at the top, then tap Forms Manager.
e Windows Mobile 5 or 6 or Microsoft Smartphone devices — choose View » Forms Manager.

The Forms Manager opens, still displaying one entry for each search form you submitted, but this time
the success status indicates that these are the response forms returned by the server.

12. View your search results pages.
e Tap the success link to display the search results for that form.
e Tap the Back button to return to the Forms Manager to view the other search results page.

Note
Tapping any link on one of your search results pages will get a Page Not Available message. If you get
this message now, tap the Back button to return to the Forms Manager.

Copyright © 2008, iAnywhere Solutions, Inc. 13
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Next steps

After the Google Test channel synchronization is successful, to create an application or mobilize an existing
desktop Web application, continue with “Mobile Application Design Guidelines” [Introduction to M-

Business Anywhere]. If this link does not work, see “The M-Business Anywhere documentation
set” on page vi for instructions on downloading this guide.

14
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